Jump to content

AIS Playbox losing internet connection when waking from standby?


SooKee

Recommended Posts

Just noticed this of late but when waking the Playbox (ethernet connected) from sleep I quite often get the AIS Playbox logo screen and a message saying 'Internet reconnecting'.  Waiting does nothing.  Can only be fixed by pulling the ethernet cable and plugging it in again.  So far I've tried changing ethernet cables, cleaning the connections and changing ethernet ports on the Asus 86U router.  Have just changed the cable again so will see how that goes.  Doesn't happen every time, maybe will wake OK 3-4 times then I get a drop-out.

 

I have several devices connected to the router and it's only the Playbox that seems to be losing the connection.  The Shield never has this problem and I've even tried the Playbox in the port that the Shield was using in case a port was failing (doubtful).  Will likely try a factory reset of the Playbox if that fails to resolve it will contact AIS, maybe the box has developed a fault.  Anyone else getting the problem?

Link to post
Share on other sites

  • Replies 84
  • Created
  • Last Reply

Yeap....that has occurred ever since I've had AIS Playboxes, old or new model boxes....before and after box neutering also.   It's completely inconsistent in when it wants to do it on both my boxes....one box may do it while the other will not.  Sometimes I can go a few weeks without it occurring....then other times it seems it wants to do it once daily for a couple of days....then the problem just disappears for maybe a few weeks.  And as mentioned it may happen on one box but not the other.  Over the last week it seems one box likes to do it every day or two.

 

Sometimes when the message appears you can click continue...it takes you to a Playbox internet connection menu which presents a Wifi and Ethernet connection selection.  If connected via Ethernet and you select the Ethernet selection another menu opens showing four or so boxes with IP-related addresses with one or more boxes being empty...but wait a few seconds and the empty boxes sometimes gets populated...back out of that menu and you now have an internet connection...TV is playing.   Other times that does not work.  Sometimes briefly unplugging and replugging the Ethernet cable into the box works....sometimes it don't.  

 

I have both boxes connect via Ethernet but have tried Wifi connections....problem still occurs.

 

What always works is turning the box off and on....that is, using the off-off switch....when it finishes rebooting (doesn't take long) you'll have the connection back.  

 

Don't waste your time in doing a box reset....I've tried that on the old and new boxes in the past several times....didn't help...doesn't prevent the problem from coming back.  Pretty sure I have tried everything else under the sun in terms of box settings, Android settings, clearing Data/Cache, etc....etc....etc.   I'm about 99% sure the problem is on the AIS server end although it sure looks like the box is just having a hard time making the basic connection to your router.

 

 

 

Link to post
Share on other sites

Ah cheers. Looks like a design glitch somewhere as opposed to network problems. One thing I can say, I think with pretty much certainty, is that I never had this problem pre the firmware update.

Link to post
Share on other sites

I haven't noticed this issue.

 

I might consider assigning a static local IP address (192.168.x.x) for the playbox's MAC address in your DHCP router. See if that affects the problem at all. 

 

 

Link to post
Share on other sites

45 minutes ago, mtls2005 said:

I haven't noticed this issue.

 

I might consider assigning a static local IP address (192.168.x.x) for the playbox's MAC address in your DHCP router. See if that affects the problem at all. 

Already tried that (several times in the past)...doesn't help.  

Link to post
Share on other sites

One thing I am just trying, whether it will have any effect or not, I did change the DNS servers on the router from automatic to the Google DNS.  I've just switched it back to automatic, will see if I still get the problem over the coming days / weeks. 

Link to post
Share on other sites

I doubt that it will because in those cases where it's not making a connection if you go quickly into the Wifi/Ethernet connection menu I talked earlier it will show the DSN being used as 8.8.8.8 (google) but once it makes a connection it then changes to a 192 series which means it using whatever DNS setting is set in router...automatic or whatever DNS you use which would be google which you have just set as a test.

 

Plus I would think what DNS AIS uses would definitely be the best one to make a connection with its own TV servers.  

 

What makes it so hard is how this problem comes and goes....it can disappear for weeks and then come back intermittently for a few days....then disappear for a few weeks...etc....etc.....etc.

 

Although this particular problem appears on the surface as just not making a connection to the router like I mentioned before it could very well be it not connecting to its TV servers and then gives a type error that makes you think its a basic box to router connection problem.   

 

Fortunately it don't happen too often any more but I remember back when I had the old unneutered box there was times it was bad....hard to get a connection....had to turn off and on (a complete power down and up) to get a connection.  Then once again the problem could disappear for weeks but then come back again for a day or two....then disappear again...etc.  And it did it when I had it connected to three different routers, one of which was the AIS provided Hauwei router.  

 

 

Link to post
Share on other sites

So you tried using a static IP address and you experienced the exact same issue? With the same frequency? Over an extended time period?

 

Again it sounds like the AIS box is retaining an IP address which your router has doled out to another device. Does your DHCP router hand out the same IP address to the AIS box all the time?

 

In one AIS configuration, I have a secondary router, in WDS mode connected to the AIS Huawei (primary), with the AIS box connected to it via ethernet. Never have any connectivity issues. The AIS box should show up as device type: dhcpcd-5.5.6.

 

When you experience this issue what does your DHCP table look like? Does this happen when you connect the Playbox via WiFi?

 

I searched Thai social media briefly and didn't see any mention of a similar problem. 

 

 

Link to post
Share on other sites

Two ways to assign a static IP from my Asus routers....both of them do the same thing except in a little different manner.

 

(1) MAC and IP Address Binding which is nothing more than a switch you turn on within the router for any item that is connected at the time which takes the IP address assigned at the time to a specific MAC and from then on that same IP address will be issued to that MAC address.  Like if IP address 192.168.2.24 was assigned to the Playbox then from now on that same IP address will always be issued to that Playbox.  Doing it this way did not help.

 

(2) Manually Assign where you can pick a specific IP address to be assigned to that MAC each time.    Say 192.168.2.24 was currently assigned and even through it may never-ever change but for some reason you wanted  to use IP 192.168.2.75, just change the .24 address to .75 and turn on that setting.  Then from now on that IP address will be issued to that Playbox.  Doing it this way did not help

 

And before continuing on, with routers now days when the lease time is up on an IP address unless the router is running low on 192.XXX IP addresses, which is highly, highly unlikely since it usually has around 250 it can hand out for a typical setup, the router is going to automatically reassign the same IP address based on the experience with my routers.  It basically simulates a static IP type setup.

 

Now within the Playbox internet connection settings you can turn DHCP on or off.  If you turn off DHCP you can manually enter a specific IP address, DNS, etc.,...click Submit and it retains that while the box is on or in standby.  Doing that did not help. 

 

The Playbox DHCP on-off setting will only stay set to off if the Playbox is powered up or in standby; if the Playbox losses power like a brief power outage of a second which is not uncommon, you decide to do a hard reboot by using the power switch, etc., then the DHCP setting automatically defaults to on.  But since the IP is being assigned by the router, whether the Playbox is using DHCP to pickup the IP address or DHCP is turned off and it expecting a specific IP address shouldn't matter as it just wants any old IP address to work.

 

I've never looked at the router DHCP table when this happens to see if the router is setting/issuing an IP address to the Playbox or not as I've just concentrated on trying to get the Playbox to make a connection by going to the Playbox internet settings to see if it then magically then grabs an IP address (which it does sometimes), remove & reconnect the Ethernet connection, or hard reboot.   A hard reboot works 99% of the time of first try...the other two methods work somewhere over 50% of the time.   Next time when the problem occurs and the situation allows I may take a look at the router DHCP table to see if it reflects a connection/IP address assigned....but don't know what I would do with that info in terms of trying something different.

 

Problem occurs using an Ethernet or Wifi connection (2.4 or 5Ghz)...I use Ethernet connections but have tried Wifi when having this issue.   With the Wifi connections the Playboxes and routers are within approx a half a meter or four meters apart...line of sight. 

 

Fortunately the problem don't happen too often now (in the past it did...go thru spells of being in a bad mood).  But really it should almost never happen as none of my other numerous devices which connect to my routers via Ethernet or Wifi experience this problem.  When you turn-on a TV box like walking into the room or from your bed in the middle of the night, you just want it to start playing video...you don't want to have to reboot it/start playing with settings to get it to grab an IP connection.  

Link to post
Share on other sites

Yes I noticed that the PB appeared to be unconnected when I opened 'Settings / Network' when the problem arose but that it had the 8.8.8.8 address which I assumed was it's last known DNS setting picked up from the router, seeing as that was the DNS I had set in the router.  Having set the router back to "Automatic" for DNS I've yet to see what it will show as the DNS in the event of a connection loss,  I'm still waiting for the problem to surface again.  I also thought that the Playbox connecting through AIS preferred DNS would likely be better than forcing a user selected DNS (where needed those DNS can always be set on the device, doesn't need to be at the router).  

 

I also have the device set to pick up the same IP address via the MAC address reservation table.  Thought I had set it before but that was the old Playbox, not the new one.  I also have no other problems with any other device connecting to the router by ethernet or wifi (I haven't tried the Playbox with wifi though).  Will see how it goes.

 

Quick update:  very odd with trying to assign a static IP to this, as in seemingly not possible.  I input the Playbox MAC address into the table, assign the IP address but, the Playbox after reboot does not take that IP address, instead insisting in taking ###.###.##.181 every time, no matter what you do.  It's as if it's somehow configured in the Playbox to not accept a router assigned IP.  I've tried it with DHCP in the device (an 'option' I don't recall seeing on other devices) set to on and off, no go, insists on assigning the 181 address itself, but, at least in that regard, it is getting the same assigned IP address every time, even if you aren't responsible and can't control it.  As Pib says, set DHCP off in the device and whenever there's a hard reset it defaults to on.  Could have sworn I'd set the Mac IP address reservation table before for this, I had, just wasn't working so I assumed it was the old box.

 

First device I've ever seen where an IP address cannot be controlled and 'force assigned' by Mac reservation table on a router.

Link to post
Share on other sites

The plot thickens with this!  I think something is up on the router end.  Just tried assigning a reserved IP address to my phone which on the network had ###.###.##.9.  Doesn't work!  Fill in the  MAC address, assign the IP address, turn wifi off/on (even tried rebooting the phone) no joy.  Still picks up the IP address it had before ending in 9.  It's as if devices are being remembered by the router and, once it has been given an IP address, it's getting automatically reserved for it.  When I'm in the Mac reservation table all of the devices are there in a pull down at the end of the field where you'd enter the MAC address.  Selecting it populates the 'save' list with it's MAC address, it's current IP address which you can then edit and save.  Except the assignation doesn't work.  I'm wondering if this is as the result of some Asus firmware upgrade or a setting I've messed up.

 

Need to explore this as I prefer to use IP addresses I assign rather than one the router is choosing, even if it's the same one. 

 

 

Link to post
Share on other sites

Above router problem sorted.  Think something may have gone awry with the last firmware upgrade.  Re-flashed it and all seems to be working now.  Panic over.

Link to post
Share on other sites

1 hour ago, SooKee said:

Yes I noticed that the PB appeared to be unconnected when I opened 'Settings / Network' when the problem arose but that it had the 8.8.8.8 address which I assumed was it's last known DNS setting picked up from the router, seeing as that was the DNS I had set in the router.  Having set the router back to "Automatic" for DNS I've yet to see what it will show as the DNS in the event of a connection loss,  I'm still waiting for the problem to surface again.  I also thought that the Playbox connecting through AIS preferred DNS would likely be better than forcing a user selected DNS (where needed those DNS can always be set on the device, doesn't need to be at the router).  

 

When/if the problem comes back if you "immediately" go into the network settings when the no connection message appears you can catch it showing 8.8.8.8 for the PB DNS until it makes a connection then the DNS changes to 192 series (i.e., it now relying on the router).   I've seen this numerous times over the last couple of years with the old and new boxes...neutered and unneutered....when using three different routers...in playing around with this problem....trying to find a fix....which I'm pretty much given up on as I've tried everything (numerous times) I can think of. 

 

I've even thought about making an Ethernet cable wired to the T568A configuration vs T568B configuration to see if that might fix the issue when making a connection via Ethernet.   The later B configuration is predominately used/sold now days and that's how all my Ethernet cables are wired.  But I haven't done it yet since the problem also occurs with a Wifi connection....so if it does it on a Wifi connection also then it can't be an Ethernet wiring configuration issue. 

 

image.png.df4991282142b1ddfdfbe945cf45315f.png

Link to post
Share on other sites

Very strange eh?  As I had actually been using Google DNS on the router I'd assumed that was where is was coming from.  Obviously not.  Not a big deal and thankfully it's not too common, but still a PITA having to pull the cable from it every now and then to get it to reconnect.  Only just noticed it recently and I'm fairly certain not before the FW upgrade (or it's possible I wasn't using it enough in light of the awful UI before the fw upgrade). As we both have the same router, be interesting to if others are getting the problem with different routers.

Link to post
Share on other sites

As mentioned earlier I've experienced the problem on three different routers....two of them are different model ASUS routers and one is the original AIS-provided Huawei router.   Right now one of my Playboxes connect to the ASUS 86U router and the other to the ASUS 55UHP.   The ASUS 55 is set to Access Point mode and connects to the primary 86U router upstairs via an Ethernet run.   The Playbox upstairs connected to the 86U does experience the problem more often than the downstairs box connected to the 55.   And before I got the 86U, the AIS-provided router used to be the primary router and the upstairs Playbox hooked to it (would have this problem even when connected to the Huawei router).  But now the AIS router is set to bridge mode and the ASUS 86U is the primary router on my home network.   It's just a strange and intermittent problem. 

 

I'm not surprised it don't get talked about much because it is intermittent....can disappear for weeks and then come back for a few days....then disappear for a weeks again....etc.   I'm still not sure if it Playbox hardware/firmware related, local AIS network related,  or AIS TV servers related. 

 

Plus, I expect a lot of people (especially many Thais) completely power down (i.e., no power applied) the Playbox when not in use due to power problems/spikes in Thailand and just to save a little on the electric bill.  Seems that how most my Thai relatives out in the province do things with most things electrical.  Come home from work or school, power stuff up, and since the problem is much less likely to happen from a power-up vs just coming out of standby then they don't see the problem very often....not enough to complain about especially since it seems to take a lot more to get a Thai to complaint about something compared to most farangs.

 

When you go to the AIS Fibre Playbox troubleshooting page, here's what they tell you do do when you can't get a connection via Ethernet.  I figure the only reason they put this Q&A on the site is because they get a fair amount of calls for some folks regarding Playbox connection problems...problems in connecting to the router.  An AIS engineer told me the reason they mention the Playbox should be connected to LAN Port 4 if using an ethernet connecton is because that's "where they expect to see it" for certain reasons like for updates/remote troubleshooting, but it will work fine/update on any port....and of course it's not connected to any Ethernet port when using a Wifi connection.  Plus several years back when AIS installed my first Playbox the install tech used Port 1 on the router for the connection.   I've had the problem on Port 4 or any port I hooked it to.  I've tried so, so many things for the two years or so I had Playboxes.  It's just an intermittent thing that don't happen to often and a power reboot is usually the best way to ensure you get a connection.

 

image.png.2f6b5dbcb5261ebee88f086f26967390.png

 

Link to post
Share on other sites

1 hour ago, SooKee said:

Above router problem sorted.  Think something may have gone awry with the last firmware upgrade.  Re-flashed it and all seems to be working now.  Panic over.

Not all routers clear tables after you assign IP to MAC address. If a lease is already active the router might not immediately switch to your new plan until existing connections are released or fresh request made.


Android has some sleepy power saving functions around its network connection and its quite common for developers to introduce wake up problems.  


Have you tested your troubled Android device with its network set manually on a IP out of your routers DHCP range. 


Android devices should always hold manual network settings after power cycle and have no need to worry about a lease after sleep. If after power cycle the device goes back to auto network there is a problem with firmware or startup checks. 

 

Link to post
Share on other sites

Not all routers clear tables after you assign IP to MAC address. If a lease is already active the router might not immediately switch to your new plan until existing connections are released or fresh request made.

Android has some sleepy power saving functions around its network connection and its quite common for developers to introduce wake up problems.  

Have you tested your troubled Android device with its network set manually on a IP out of your routers DHCP range. 

Android devices should always hold manual network settings after power cycle and have no need to worry about a lease after sleep. If after power cycle the device goes back to auto network there is a problem with firmware or startup checks. 
 


Yeah it's working ok now. Reboots get the correct IP assigned now. Will wait for the problem to re-enter surface. Problem before was when I hit Apply to the new IP reservations, it didn't. Looked like it was, until reconnecting, then back to the previous one.


Posted using Tapatalk
Link to post
Share on other sites

Just some crossfeed from some testing last night and this morning.  I think most of us just "short" press the PB remote power button to put the PB to sleep.....then a quick press to turn it back on.  When turning it back on it up and displaying TV within "approx 15 seconds" assuming it made an internet connection; otherwise, you get the "not making an internet connection" type message briefly or the message don't go away until it does make a connection by doing a reboot or something.   

 

Last night I turned the PB off a different way by doing a "long" press of the remote power button...up pops a choice of Power Off or Restart. I select Power Off.   Now after turn the box back on from a Power Off it takes "approx 30 seconds" to start playing again....you will the AIS Play icon displayed three times during this boot-up sequence compared to the approx 15 second boot-up time and the AIS Play icon usually displaying only once during boot-up.  So, the long-press Power Off selection apparently puts the PB is a deeper sleep/standby mode compared to a short-press turn off.

 

Anyway, last night when shutting it down using the long-press method six times and then turning it back on, two times for sure and maybe it was three times I briefly got the "no internet connection" type message which might last a few seconds and then the TV would start playing.... or you get the internet message, it does not start playing after waiting 15 seconds or so but when going into the internet connection Wifi/Ethernet menu you see all 4 boxes are now populated with IP info, back out of that and the PB is now showing TV.  And this morning after watching TV for a while I did one long press power off and then power back up, got the no internet type message, went into the internet menu, now see it populated with IP info, back out of that menu and the PB is playing TV.  

 

Now before doing these long press power downs I had been watching TV, turned the PB off with the short press method, started the box back up again and TV always started playing---didn't have no problem in making an internet connections.

 

So maybe this problem is related more to the "depth of sleep/standby" the box must come out of.  With a complete power off (I mean no power to the box) it's coming totally back to life.  From a long-press power down it coming out of a "deep" sleep maybe....and from a short-press power down it coming out of a "not so deep sleep....just a nap with one eye kept open" unless it's been napping say for a few hours where it automatically shifts into a deep sleep.

 

Now in the PB Common Settings  you can set the Auto Standby setting to 3, 5, 10 hours or Never.  I think this setting just means if a person does not press any button on the remote, like changing a channel, volume up or down, etc., within a certain time frame the PB will assume "Elvis has left the building" and shift into standby.  The default setting is 5 hours but I have tried the Never selection and the no internet connection issue can still occur.

 

Anyway, the more I play with the interment, not too often occurring problem I now think it's just an issue of the PB just fails to get a local router connection vs connection to AIS TV servers when coming out of standby/sleep (nap or deep) unless maybe the router its connecting to "gets along with the PB super well."   Summary: it's just a PB hardware/firmware issue....low cost box issue.....I don't have this issue with any other devices I connect to my router via ethernet or Wifi.    But it would be nice to find some minor tweak on the PB or a person router to make the problem never occur.  

 

 

  

Link to post
Share on other sites

Yes I think it is just down to this box, design and firmware implementation.  I do just the short press on / off.  Will continue to do so.  It's pretty quick to push the picture to the screen but it's also waking the sound bar via CEC.

 

I have my 'Auto-Standby' set to 10 hours.  It does do just that, if you don't interact via the remote within 10 hours it will automatically go to standby, it will display a message for about a minute before doing do along the lines of "Playbox will sleep within 1 minute, press any button on the remote to continue", where continue means watching.  It also has to be the AIS remote, another remote, such as an air-mouse connected by wifi dongle, won't interrupt the shut down.  I often just have the TV on in the background when I'm working at home and I found 5 hours too short for shut down.  I do like to leave it on though as, after a power cut, the box will re-start once the power is restored.  Luckily power cuts are very few since all the cabling was replaced here. 

Link to post
Share on other sites

  • 1 month later...

FWIW, quick update on this.  Some weeks back I went into the router and doubles the default lease time on DHCP from 86,400 seconds to 172,800 seconds.  Since doing that, no more loss of internet and "internet connecting" message.

Link to post
Share on other sites

1 hour ago, SooKee said:

FWIW, quick update on this.  Some weeks back I went into the router and doubles the default lease time on DHCP from 86,400 seconds to 172,800 seconds.  Since doing that, no more loss of internet and "internet connecting" message.

Well, I'll give that a try....just changed my lease time from 1 day to 2 days as you did.   

 

"On the surface" I would respond this ain't going to work because the way DHCP lease time works in router just before the lease time is up the router will check to see if the device is still in use and if it is it will almost always just reissue/extend the exact same IP address effectively turning it into a static IP address.  It's still a dynamic process but it's just it gave the device the exact same IP address again....just extended it for another lease cycle.  And that is exactly what what's been going on with my Playboxes and most other devices as I've monitored that in the router while working this issue.  

 

And since we had both tried the static IP setting thing and it didn't help on the surface right now I'm doubtful increasing the least time from 1 to 2 days will help. 

 

HOWEVER, BUT, what a person sees on the surface doesn't mean other mysterious things aren't happening beneath we can't see/understand.  And believe it or not I've thought about increasing the lease time numerous times, but since the IP address rarely changed even with a 1 day lease time due to the same IP address just being reissued to the Playbox I just never gave it a try.  And to re-mention I had tried the static IP thing also.

 

But this week I did try another thing.  On that same Asus router 86U page where you can adjust the lease time...in fact, directly below the lease time setting is a Default Gateway setting that by default is blank as shown below.  As the default it uses the router's gateway setting but it does not display it. Cursor over the Default Gateway words and a Help popup explains that. 

 

But I entered the router's gateway setting anyway to see if it might help and since sometimes when looking at the Playbox ethernet connection info when I get that no connection message its Gateway field is empty....that field reflects the router's Gateway address that it gets from the router when it does make a connection.  But it didn't help as the next day I got the no internet connection message again so I set it back to being blank.

 

image.png.bba5df36b660272c4d857f340acb19e0.png

 

I also tried the static IP things again this week but this week instead of just retaining the IP address that was already issued and making it static I changed the last set of numbers in the address to a low number....changed it to .15 since some IT pundits say setting it to a number below .20 can help many times.   But that didn't help either...after around 2 days got the connection message again so I just removed the static IP setting; went back the DHCP.

 

Keeping my fingers crossed this lease time change will work.   If it does I will know within a 1 to 3 days as I usually can't go that long on one of the Playboxes without getting the no internet connection on one of the Playboxes; on my second Playbox it can sometimes make it a week or so.  Of all the devices I have hooked to my home network the two Playboxes are the only two devices that act up.

 

Link to post
Share on other sites

4 hours ago, SooKee said:

FWIW, quick update on this.  Some weeks back I went into the router and doubles the default lease time on DHCP from 86,400 seconds to 172,800 seconds.  Since doing that, no more loss of internet and "internet connecting" message.

I asked earlier if you have tested with a static ip address assigned manually at the device. This would help prove the device is not taking care of its ip lease during sleep periods. Extending the lease period does the same but is not best practice.


There is often confusion over ip lease periods and who should be in charge of renewal. The following video explains the DHCP protocol and how clients are responsible for lease renewal requests.

 

 

Link to post
Share on other sites

Sometimes there is comfort in misery like below Pantip forum thread talking the same Playbox connection problem...how it occurs every few days.....and how AIS Support basically tell him to reboot, etc.  The thread is titled a Playbox firmware problem but they are talking the intermittent no internet connection issue we have been talking....that is, the Playbox intermittently not getting an IP address issued from the router although your router works fine with all the other devices in your house connected to it.   The thread is in Thai but Google Translate does a fair translation as shown in below snapshot/partial quote....see weblink for more info.

 

https://pantip.com/topic/37659970

image.png.9cdadc72bf29e96a24dfb74343ede0cb.png

 

Link to post
Share on other sites

I asked earlier if you have tested with a static ip address assigned manually at the device. This would help prove the device is not taking care of its ip lease during sleep periods. Extending the lease period does the same but is not best practice.

There is often confusion over ip lease periods and who should be in charge of renewal. The following video explains the DHCP protocol and how clients are responsible for lease renewal requests.
 
 
I have a static IP assigned to the device by the router which doesn't cure the problem, in fact, after I did that it seemed to get worse than ever. Haven't tried doing anything from within the Playbox itself. From memory I couldn't do much from within the Playbox. Any time I did and then had to reset the box it'd just reset itself and turn DHCP on. Been a while now so it's all quite a blur but like I say, coincidence or not I don't know, but no more problems (yet) since changing the lease time.
Link to post
Share on other sites

5 hours ago, SooKee said:

I have a static IP assigned to the device by the router which doesn't cure the problem, in fact, after I did that it seemed to get worse than ever. Haven't tried doing anything from within the Playbox itself. From memory I couldn't do much from within the Playbox. Any time I did and then had to reset the box it'd just reset itself and turn DHCP on. Been a while now so it's all quite a blur but like I say, coincidence or not I don't know, but no more problems (yet) since changing the lease time.

If you assigned ip at the router with MAC id it will keep the device in the lease agreement. If you set a static ip gateway and DNS at the device it will be out of DHCP control and have values ready for when it wakes up from sleep. Remember that a static ip set at the device must be out of the DHCP range set in your router. 

 

Example. My home router has 192.168.1.20 upwards for DHCP use and anything below I use for static devices like TV boxes HTPC and server.

Link to post
Share on other sites

1 hour ago, maxpower said:

If you assigned ip at the router with MAC id it will keep the device in the lease agreement. If you set a static ip gateway and DNS at the device it will be out of DHCP control and have values ready for when it wakes up from sleep. Remember that a static ip set at the device must be out of the DHCP range set in your router. 

 

Example. My home router has 192.168.1.20 upwards for DHCP use and anything below I use for static devices like TV boxes HTPC and server.

On Asus routers like SooKee and I use a person can manually assigned IP addresses around your DHCP scope.  And by around I mean the IPs can be inside the DHCP scope....the router just reserves them in the DHCP pool and makes them static...basically taking out of the DHCP pool....some router brands call this a "Reservation" in their menus like I think TP-LInk routers do.  You can have up to 64 static out of a typical 253 DHCP scope. 

 

 Like in the 1st router snapshot below....at the bottom of snapshot you do a "manual" assignment of the iP you want the device to always (static IP) use and it will then appear as a manually assigned (static) IP.   

 

Or in the 2nd router snapshot below you can create a static IP by just clicking the "MAC and IP Address "Binding."  Then if you go back to snapshot one you'll also see it now listed in the manually assigned IP area. 

 

Just two ways to create a static IP in Asus routers.

 

Now within in the Playbox itself if connecting via Wifi there is no selection for DHCP or Static like in an Android phone....no advanced settings like in a Android phone where you can select DHCP or Static...you can only enter your Wifi credentials to make a connection. 

 

And in the Playbox ethernet connection you can turn DHCP on or off.  If turning it off you can enter the IP address, submask, gateway, and DNS and then click Submit which I guess is like setting a static IP....saying it wants that IP address only.  But even with then going into your router and setting a static IP to that particular address it has not helped the situation. Plus, whenever you reboot the Playbox (i.e, turn power switch on and off...or maybe a brief power outage occurs) the DHCP setting automatically turns back on....it's a firmware default setting. 

 

image.png.0bdbf5ad5533307f657b51f308822a2f.png

 

 

image.png.c3caac4ada8c87eea9e0befffef649f0.png

Link to post
Share on other sites

1 hour ago, maxpower said:

If you assigned ip at the router with MAC id it will keep the device in the lease agreement.

Yes, but even with a static IP a lease time is still assigned (the best I can figure out from googling and youtubing "lease time" use for a static or dynamically assigned IP)  in the communications between the client and router (DHCP Server).  It's just when the lease is renewed for a static IP, the IP address will "absolutely always" stay the same whereas with a DHCP IP Address "might" change.  

 

For a static IP it's like the lease time setting means nothing, but a lease time is still issued.....maybe because in the client-router communications it's expected otherwise an error might occur.  

 

"Maybe" the lease time setting is the key to this Playbox issue; maybe not.  Too early for me to say, but I have had my router lease time changed from 1 day to 2 days since lunch time Saturday and neither Playbox has presented me with the no internet connection message yet.   But since it's only been about 30 hours since I made the change it's too early to tell if this has helped yet as sometimes I go for 3 or so days or a few times maybe a week without the no internet message on the Playbox.  But over the last few weeks it seems on one of my two boxes I can't get beyond 3 days without it occurring.   One of my two boxes just displays the problem more often...and they are identical Playbox models.

 

Time will tell on the lease time setting...seems it worked for SooKee.  I need more time before I can say it definitely helped me. If I can get thru 3 days with no error message I'll start feeling more confident....and if getting to a week I be feeling pretty durn sure it helped.  Time will tell.

 

 

 

 

 

  

Link to post
Share on other sites

If you assigned ip at the router with MAC id it will keep the device in the lease agreement. If you set a static ip gateway and DNS at the device it will be out of DHCP control and have values ready for when it wakes up from sleep. Remember that a static ip set at the device must be out of the DHCP range set in your router. 
 
Example. My home router has 192.168.1.20 upwards for DHCP use and anything below I use for static devices like TV boxes HTPC and server.
Cheers. Will give it a try if I need. At the moment it seems to have been cured. Will wait and see and if it breaks again, try and fix it again :)
Link to post
Share on other sites

1 hour ago, Pib said:

Yes, but even with a static IP a lease time is still assigned (the best I can figure out from googling and youtubing "lease time" use for a static or dynamically assigned IP)  in the communications between the client and router (DHCP Server).  It's just when the lease is renewed for a static IP, the IP address will "absolutely always" stay the same whereas with a DHCP IP Address "might" change.  

 

For a static IP it's like the lease time setting means nothing, but a lease time is still issued.....maybe because in the client-router communications it's expected otherwise an error might occur.  

 

"Maybe" the lease time setting is the key to this Playbox issue; maybe not.  Too early for me to say, but I have had my router lease time changed from 1 day to 2 days since lunch time Saturday and neither Playbox has presented me with the no internet connection message yet.   But since it's only been about 30 hours since I made the change it's too early to tell if this has helped yet as sometimes I go for 3 or so days or a few times maybe a week without the no internet message on the Playbox.  But over the last few weeks it seems on one of my two boxes I can't get beyond 3 days without it occurring.   One of my two boxes just displays the problem more often...and they are identical Playbox models.

 

Time will tell on the lease time setting...seems it worked for SooKee.  I need more time before I can say it definitely helped me. If I can get thru 3 days with no error message I'll start feeling more confident....and if getting to a week I be feeling pretty durn sure it helped.  Time will tell.

 

STATIC DYNAMIC RESERVED

 

A device with static network settings does not need to get involved with DHCP or lease times. Reserving an ip in the routers DHCP pool does not make a device static it just reserves an address for the device with matching MAC. To avoid confusion it is best to think of static devices as those with ip's locked in the device and outside of the DHCP pool. Now we have static ip and reserved ip without confusion.

 

If your device can only obtain network setting via DHCP please ignore the rest of this post.


My experience tells me that your Android devices are having problems with DHCP lease while sleeping.

 

The way to prove this is to take DHCP involvement and leases away from the device completely and if this cures the fault then we know the device has problems with DHCP leases only.

 

Lets stop here and say devices do not need to get involved with a DHCP server if they are capable of storing basic network settings.

 

IP address - Mask - Gateway - DNS Primary - DNS Secondary

By selecting an ip outside of the routers DHCP pool, example settings might be :-

IP 192.168.1.4 - GATEWAY 192.168.1.1 - MASK 255.255.255.0 - DNS1 8.8.8.8 - DNS2 8.8.4.4


With static settings the device can wake up and go about network business armed with its local settings. It will not need to deal with the router DHCP server and its lease times ever again.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...